Custom Kernel

Discussion in 'Linux, BSD and Other OS's' started by max12590, Jan 31, 2008.

  1. max12590

    max12590 Masterful Geek

    Likes Received:
    51
    Trophy Points:
    0
    OK, so I installed the new HWF kernel. The install appeared to work fine, so I went on. I could not get the Nvidia drivers to install properly, so I decided to boot back into the default kernel. Despite having Nvidia drivers and the exact same xorg.conf file as it did before my dual monitors no longer work. This took me days to work out the first time and I am not looking forward to doing it again. Any ideas?
     
  2. Anti-Trend

    Anti-Trend Nonconformist Geek Staff Member

    Likes Received:
    118
    Trophy Points:
    63
    You cannot use the drivers from the restricted repo in Gutsy with a custom kernel, since they're only built against specific Ubuntu kernels. You must instead follow this guide to install the Nvidia drivers the official way. Note that this method results in faster, newer and more reliable nvidia drivers than those installed automatically in Ubuntu.

    Best regards,
    -Chris
     
  3. max12590

    max12590 Masterful Geek

    Likes Received:
    51
    Trophy Points:
    0
    Ok, I think I can manage that. Any ideas on dual monitors? when I run the nvidia-settings thingy in the old kernel and enable the second monitor as a Twinview it tells me it can't enable it and asks if I want to delete that metamode.
     
  4. Anti-Trend

    Anti-Trend Nonconformist Geek Staff Member

    Likes Received:
    118
    Trophy Points:
    63
    Once you get the Nvidia drivers going with your new kernel, you should be able to setup TwinView, etc through the nvidia control panel. Make sure you uninstall any nvidia stuff that was already installed by your package manager first though.
     
  5. Anti-Trend

    Anti-Trend Nonconformist Geek Staff Member

    Likes Received:
    118
    Trophy Points:
    63
  6. donkey42

    donkey42 plank

    Likes Received:
    9
    Trophy Points:
    38
    you don't need to run nvidia-xconfig, just reinstall the grx driver & reboot

    Edit: i just reinstalled gfx drivers and ran "startx"
     
  7. Anti-Trend

    Anti-Trend Nonconformist Geek Staff Member

    Likes Received:
    118
    Trophy Points:
    63
    Yeah, but I'd bet if you run "glxinfo | grep render", you'll come back with no direct rendering. :)
     
  8. donkey42

    donkey42 plank

    Likes Received:
    9
    Trophy Points:
    38
    Code:
    Xlib:  extension "GLX" missing on display ":0.0".
    ok, smart ass :pray: the master as always :pray:, now we'll see if i can sort it
     
  9. Anti-Trend

    Anti-Trend Nonconformist Geek Staff Member

    Likes Received:
    118
    Trophy Points:
    63
    That's because that module is compiled against the stock kernel that ships with your distro. When you add a custom kernel, your proprietary video drivers will need to be compiled against it in order to work. howto:video [HWF Custom Kernel Wiki]
     
  10. donkey42

    donkey42 plank

    Likes Received:
    9
    Trophy Points:
    38
    thankies, looked online and the only possible solution was commenting out "Option List1" in xorg.conf, but i couldn't varify what this achieved so i didn't do it,

    anyway, thankies for solution i look into it[ot]maybe i was overcomplicating it as usual[/ot]
     

Share This Page