display issuses with ubuntu 9.04

Discussion in 'Linux, BSD and Other OS's' started by Dartht33bagger, Jul 20, 2009.

  1. Dartht33bagger

    Dartht33bagger Geek Trainee

    Likes Received:
    0
    Trophy Points:
    0
    My laptop I have is a Gateway MX3228. Here are the specs:http://support.gateway.com/s/Mobile/Q106/MagicLC/1008831sp2.shtml

    Right now ubuntu sets the res size to 1600 by 1200. It is far too big for the screen, half of the screen is off of the display. I need to get the size down to something like 1280 by 800. When I go to the display panel and try to change the size from there the screen screws up. There is multiple desktops that overlap each other, making it impossible to see anything.

    So I try to change it xrandr, which others have pointed me towards. It tells me can't open display. So I don't know what to do from here. If I change the display settings in the prefrences bar I end up screwing up the screen forcing me to reinstall, and every thing I've done to change the display manually tells me can't open display.

    Are there some drivers I must get for linux?
     
  2. sabashuali

    sabashuali Ani Ma'amin

    Likes Received:
    6
    Trophy Points:
    38
    Just out of interest - does this also happen when you use the Live CD or only in the permanent installation?
     
  3. Dartht33bagger

    Dartht33bagger Geek Trainee

    Likes Received:
    0
    Trophy Points:
    0
    It happens running a live CD or installed.

    Also using wine to play warcraft 3 the screen size goes to the smallest possible and overlaps.
     
  4. sabashuali

    sabashuali Ani Ma'amin

    Likes Received:
    6
    Trophy Points:
    38
    Personally, I would not stay with Ubuntu. To carry on the Debian theme, have you tried Sidux, or perhaps go with the father of both (Debian, that is)? I wonder if the same issue will happen there. The problem, I think, is that you have to rely on Mesa to manage your display (configure your X server) if you had an ATI or nVidia card, I would say to definitely install the Linux drivers. In the case of Intel's chips I am not sure what there is to do.

    You could also try to edit your xorg.conf (/etc/X11/xorg.conf) file yourself and remove the higher resolutions and stick with the ones that you know your screen can handle.
    You should look for something like:
    Don't forget to back up your xorg.conf file first (cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup). Then remove the modes you do not wish to have (in bold) and keep the ones you know will work well.

    Found this - How do i edit xorg.conf in ubuntu linux 7.10 | Answerbag.com
    and this - xorg-edit: GUI for editing xorg.conf - Ubuntu Forums

    Good luck....
     
  5. Dartht33bagger

    Dartht33bagger Geek Trainee

    Likes Received:
    0
    Trophy Points:
    0
    This is all the bottom of my xorg.conf says.

    Code:
    Section "Device"
    	Identifier	"Configured Video Device"
    	Option		"UseFBDev"		"true"
    EndSection
    
    Section "Monitor"
    	Identifier	"Configured Monitor"
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Monitor		"Configured Monitor"
    	Device		"Configured Video Device"
    EndSection
    
     
  6. Dartht33bagger

    Dartht33bagger Geek Trainee

    Likes Received:
    0
    Trophy Points:
    0
    Trying to open a terminal and then using gksudo I get cannot open display. What does this mean?
     
  7. sabashuali

    sabashuali Ani Ma'amin

    Likes Received:
    6
    Trophy Points:
    38
    Which application are you trying to run? Gedit? If so, Root may not have rights to lauch an application which needs to connect to the xserver. A Linux administrator will probably cut both my hands for this but hey.... as user:
    > yourdomain$ xhost +

    Then try again. The command above (I think) temporarily allows all users to connect to the xserver. Peronally, If I were you, I would get familliar with Vim. It is not as hard as it first seems and it means that you do not have to worry about fancy editors and their requirements.

    As for your initial problem -
    I checked my xorg.conf file and it is bare like the Saharah desert. XFCE must be taking the configuration from a file elsewhere... god only knows... :confused:

    But you could still try and add a subsection manually - something like this:
    I would strongly recommend trying another live CD to see if the problem is with Ubuntu acommedating your display adapter.
     
  8. donkey42

    donkey42 plank

    Likes Received:
    9
    Trophy Points:
    38
    [strike]think this is correct driver according to Ubuntuforums here & insructions on SF here[/strike]

    driver is for AMD64
     
  9. Dartht33bagger

    Dartht33bagger Geek Trainee

    Likes Received:
    0
    Trophy Points:
    0
    Got a debian CD and put it on there. It still sets it at 1600x1200 and when I go to screen resolution there isn't a single option in the res, or refresh spots. I just click the little drop down button and nothing appears, it just changes the color as if I selected it.

    So I go to look at my xorg.conf and it's blank now. So it looks like debian is screwed up too.
     
  10. Anti-Trend

    Anti-Trend Nonconformist Geek Staff Member

    Likes Received:
    118
    Trophy Points:
    63
    It's not a Debian or Ubuntu thing, but an X.org thing. Plus, Via's Unichrome drivers suck ass. :(

    What you need to do is hand-define the display modes in your xorg.conf, like saba suggested. You can also try eLive, which is a Debian-based live CD that has some neat scripts for detecting and setting your resolutions for you.
     
  11. Dartht33bagger

    Dartht33bagger Geek Trainee

    Likes Received:
    0
    Trophy Points:
    0
    When I tried to edit my xorg.conf with ubuntu I was not able to get write access. Typing gksudo gedit /etc/X11/xorg.conf would just say:

    Code:
    GTK WARNING **: Cannot open display
    
    So I put on debian, and I am now able to get write access to the xorg.conf, but the xorg.conf is blank.
     
  12. Anti-Trend

    Anti-Trend Nonconformist Geek Staff Member

    Likes Received:
    118
    Trophy Points:
    63
    Yes, newer versions of X.org aren't populated by default. Usually XRandR can adjust your resolution, DPI and multiple screens by itself without a config file. However, with certain scenarios (like crummy S3 drivers) you will need to populate it yourself.

    xorg.conf(5x) manual page

    If you need any help, please post again.
     
  13. Dartht33bagger

    Dartht33bagger Geek Trainee

    Likes Received:
    0
    Trophy Points:
    0
    So I went back to ubuntu and added this to the screen section of xorg.conf

    Code:
    	DefaultDepth	24
    	SubSection "Display"
    		Depth		1
    		Modes		"1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		4
    		Modes		"1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		8
    		Modes		"1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		15
    		Modes		"1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		16
    		Modes		"1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		24
    		Modes		"1024x768" "800x600" "640x480"
    	EndSubSection
    
    Now when I restart it tells me:

    Ubuntu is running in low graphics mode. The follow error was encountered, you may need to update your config to solve this.

    (EE) Problem parsing the config file
    (EE) Error parsing the config file
     
  14. Anti-Trend

    Anti-Trend Nonconformist Geek Staff Member

    Likes Received:
    118
    Trophy Points:
    63
    Please post the entire xorg.conf so we can help identify any syntax errors.
     
  15. Dartht33bagger

    Dartht33bagger Geek Trainee

    Likes Received:
    0
    Trophy Points:
    0
    Code:
    Section "Device"
    Identifier "Configured Video Device"
    EndSection
    
    Section "Monitor"
    Identifier "Configured Monitor"
    EndSection
    
    Section "Screen"
    Identifier "Default Screen"
    Monitor "Configured Monitor
    Device "Configured Video Device"
    DefaultDepth	24
    	SubSection "Display"
    		Depth		1
    		Modes		"1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		4
    		Modes		"1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		8
    		Modes		"1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		15
    		Modes		"1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		16
    		Modes		"1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		24
    		Modes		"1024x768" "800x600" "640x480"
    EndSubSection
    
     
  16. sabashuali

    sabashuali Ani Ma'amin

    Likes Received:
    6
    Trophy Points:
    38
    Is it me or the is no 'EndSection' to close the Screen Section?
     
  17. Anti-Trend

    Anti-Trend Nonconformist Geek Staff Member

    Likes Received:
    118
    Trophy Points:
    63
    Try this variation:

    Code:
    Section "Device"
    Identifier "VIA UniChrome Pro"
    Driver "openchrome"
    EndSection
    
    Section "Monitor"
    Identifier "Configured Monitor"
    EndSection
    
    Section "Screen"
    Identifier "Default Screen"
    Monitor "Configured Monitor
    Device "VIA UniChrome Pro"
    DefaultDepth	24
    	SubSection "Display"
    		Depth		1
    		Modes		"1280x800" "1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		4
    		Modes		"1280x800" "1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		8
    		Modes		"1280x800" "1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		15
    		Modes		"1280x800" "1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		16
    		Modes		"1280x800" "1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		24
    		Modes		"1280x800" "1024x768" "800x600" "640x480"
            EndSubSection
    EndSection
    
    I took into account your WXGA resolution (1280x800 in your case, from what you've told us), and the chipset you have which is the VN800 UniChrome Pro. If that doesn't work, try running the following:

    Code:
    sudo dpkg-reconfigure -phigh xserver-xorg
    ... and choose "openchrome" when prompted.

    As I mentioned before, the Unichrome chipset has horrible Linux support, so 3D may be troublesome. However, it does work for some people. If you feel adventurous, look over here for some tips on how to get that going.
     
  18. Dartht33bagger

    Dartht33bagger Geek Trainee

    Likes Received:
    0
    Trophy Points:
    0
    Making the changes to xorg.conf as you posted above still gave the same error.

    So I did the other things you posted and it never prompted me to choose a driver. It instantly said this after I typed my password:

    Code:
    xserver-xorg postient warning: Overwriting possibly-customised configuration file: backup in /etc/X11/xorg.conf.20090724042914
    
     
  19. Anti-Trend

    Anti-Trend Nonconformist Geek Staff Member

    Likes Received:
    118
    Trophy Points:
    63
    Yes, that's to be expected. You can move the old xorg.conf to xorg.conf.backup if you prefer.
     
  20. Dartht33bagger

    Dartht33bagger Geek Trainee

    Likes Received:
    0
    Trophy Points:
    0
    I ended up finding my old XP disc and putting that on it. Much easier. The drivers work fine for XP and now its working great.

    Thanks for all the help anyways! I wish I could have used linux on it.
     

Share This Page