Help with HWF custom kernel

Discussion in 'Linux, BSD and Other OS's' started by Anti-Trend, Jun 23, 2009.

  1. Anti-Trend

    Anti-Trend Nonconformist Geek Staff Member

    Likes Received:
    118
    Trophy Points:
    63
    You might want to try 2.6.29.5, especially if you have ATI graphics. 2.6.30 has some issues, and ATI is apparently too far behind in the development game; their drivers won't build against '30 yet.

    Also, what CPU do you have? If it's a later p4 like a Prescott or Pentium-D, you can use the prescott build for better performance.

    http://kernel.hardwareforums.com/about
     
  2. donkey42

    donkey42 plank

    Likes Received:
    9
    Trophy Points:
    38
    apt-mirror

    it's actually an NV GeForce2 Ti :crying:

    P4 (old single core)
    well i can only try

    probably will when system up & running, think need custom rolled kernel for NIC and possibly mouse, may just get Intel Pro NIC, be easier
     
  3. Anti-Trend

    Anti-Trend Nonconformist Geek Staff Member

    Likes Received:
    118
    Trophy Points:
    63
    apt-mirror

    Wow, old-school. Luckily the sgfxi script will automatically patch NVidia's legacy drivers against newer kernels and should be able to make it work for you.

    You can cat /proc/cpuinfo which will give you detailed info about your processor. Once you have the model and stepping revision, you can look it up to see what you've got.

    Why do you need a custom kernel to get a NIC working? What kind of NIC do you have now? :confused: The HWF kernel is rolled with all the latest open-source drivers as modules, so anything that's officially supported by Linux should work.
     
  4. donkey42

    donkey42 plank

    Likes Received:
    9
    Trophy Points:
    38
    apt-mirror

    well because we couldn't get NV 6200 working properly i slung this old Ti in

    :beer:, model: 6, stepping: 5, where ?

    boot msg "not an 8139C+ compat chip / card, 8139cp 0000:00:09.0: Try "8139too" driver"

    i presume 8139 is compiled as loadable module & 8139too is not
    crappy onboard sis, pinging google.com & .co.uk returns "unknown host" NIC down / not compat
    dunno

    BTW: cli only, using crappy vista
     
  5. Anti-Trend

    Anti-Trend Nonconformist Geek Staff Member

    Likes Received:
    118
    Trophy Points:
    63
    apt-mirror

    Didn't forget to plugin the extra molex power connector, did we? Hehe. ;)

    If the "cpu family" = 15, you probably have a Pentium D. That's actually an early dual-core, in which case you'd be able to use the Prescott build. The P4 build does include some optional Prescott optimizations though.


    From the HWF kernel config:
    Code:
    CONFIG_8139TOO=m
    It's there. Also, pinging a site by domain name doesn't establish whether or not a NIC is working. Really it's more of a test of DNS functionality. If you want to use ping as a diagnostic, you might be better served by pinging the IP address of your next hop, e.g. your router's internal interface, instead.
     
  6. donkey42

    donkey42 plank

    Likes Received:
    9
    Trophy Points:
    38
    apt-mirror

    poss, don't remember doing that, don't know where 6200 is now will try find it

    are you p-sycic, it is 15
    oh, so 8139too is a loadable module, so why is kernel using 8139 and not 8139too, as it can recognize the existance of 8139too, need do some googleing
    oh, ok well pinged router & network unreachable

    Edit: are modules autoloadable if not make not load 8139 & make 8139too load
     
  7. donkey42

    donkey42 plank

    Likes Received:
    9
    Trophy Points:
    38
    found it and 6200 doesn't have molex connector & neither does old Radeon 7k i found

    BTW: disabled onboard net and inserted v v old NIC (got BNC connector) think it's NE1000 compat :unsure:
     
  8. Anti-Trend

    Anti-Trend Nonconformist Geek Staff Member

    Likes Received:
    118
    Trophy Points:
    63
    Yeah, modules can be loaded automatically from your boot scripts. But, if it's using the wrong driver, try this as root:

    Code:
    rmmod 8139
    modprobe 8139too
    /etc/init.d/networking restart
     
  9. donkey42

    donkey42 plank

    Likes Received:
    9
    Trophy Points:
    38
    this learning think i a pain, i'm on default install, with no net & Gnome, but a couple of errors on boot will research & think
     
  10. Anti-Trend

    Anti-Trend Nonconformist Geek Staff Member

    Likes Received:
    118
    Trophy Points:
    63
    If you need help feel free to start a new thread. :)
     
  11. donkey42

    donkey42 plank

    Likes Received:
    9
    Trophy Points:
    38
    thankies, but i would prefer it if i was able to fix it, however, i'm not stupid, i will ask when i think i'm out of my league
     

Share This Page