M-audio Delta 1010lt And A Silent Microphone

Discussion in 'Sound Cards and Speakers' started by Fionar, Nov 10, 2014.

  1. Fionar

    Fionar Geek Trainee

    Likes Received:
    Trophy Points:
    Good day, hardware enthusiasts!

    I have an issue with getting my microphone to operate correctly with an older soundcard. The card in question is the M-Audio Delta 1010LT, and is to be used solely with the Rode NT2-A microphone. The microphone is connected to a Behringer Xenyx 502 mixer which, in turn, is connected to the soundcard itself.

    The cables are set up correctly, as this setup has worked flawlessly in the past. However, when attempting to use it on the current system, I have run into a peculiar issue: the microphone does not seem to properly pick up on sounds. When recording audio in Audacity, the recorded sound can not be heard unless amplified significantly, and even then, it is plagued by low quality and a lot of static noise.

    Furthermore, when I open M-Audio’s control panel and navigate to the ‘input’ tab to review the visualisation of input received through the microphone, the input seems to be spread out over all channels. Those being ‘Line 1/2'; ‘Line 3/4'; ‘Line 5/6’ and finally ‘Line 7/8’. As with the sensitivity issue replicated in Audacity, it only seems to pick up sound when I tap the microphone, whereas normally I would expect the microphone to visibly pick up on even the faintest of sounds in my environment.

    In an attempt to solve this issue myself, I have tried numerous alternatives. Firstly, I have tried several different iterations of drivers for the soundcard, ranging from 5078 down to 5069, the one it is currently running on. Next, I have tried changing the IRQ priority from 17 to 1 and 20 in the registry. And finally, I have tried disabling any other soundcard in device manager, those being my ASUS Xonar and the on-board High Definition Audio Devices. None of these alternatives have had any impact whatsoever on the issue at hand.

    The M-Audio Delta 1010LT is the only card occupying a PCI slot on my motherboard. Here is a list of the system specifications I am currently working with:

    CPU: I5-4670 @ 3.40GHz
    GPU: Nvidia GTX760
    Motherboard: ASUS Z87-C
    Soundcard 1: ASUS Xonar D2X
    Soundcard 2: M-Audio Delta 1010LT
    OS: Windows 7 64x Service Pack 1

    In short, I need help getting my microphone to work properly with my soundcard, as it currently fails to pick up properly on any sound I produce. While it does pick up on sound, it is only faint and ridden with static noise. If anyone could be my saviour and help me solve this issue, I would be most grateful.

    Kind regards,



    After going through various solutions and methods posted in other threads, and after a little bit more research, I have come to the conclusion that the mixer has a defective input stage. This was caused by disconnecting the microphone while the mixer was powered; due to the fact the phantom power is switched on permanently, doing this likely fried the input.

    Time to get another mixer, then!
    Last edited: Nov 11, 2014

Share This Page