Solved (need Expert Help - Enters Bios But No Display)

Discussion in 'CPU, Motherboards and Memory' started by MBee47, May 31, 2021.

  1. MBee47

    MBee47 Geek Trainee

    Likes Received:
    Trophy Points:

    I read elsewhere that if you find yourself in this position, simply remove any add-on graphics card, connect your on-board graphics adapter to your display, and reboot. You will find that now you will see and can enter the BIOS setup.

    - - - - - - - -


    Until two days ago and for about a week, when I booted up my ASUS Z97-A/USB3.1 home-built desktop running 64-bit Win 10 Pro 1909, my displays remained blank for around 5-7 minutes. Then -- without ever visibly showing the BIOS screen. With nothing visible, there was no way for me to know when to press DEL or F2, though I tried scores of times anyway. After the 5+ minutes, the correct Windows installation booted up fine. The first thing I ever saw was the Windows user/password screen, after which there were no obvious problems.

    I have a dual monitor setup, with one connected to on-board Intel video port, and the other connected to my HGTV via my nVidia GTX-750. I am 100% certain that the monitors and ports are working, since they worked fine when Windows finally booted up.

    The Z97-A manual provides several ways to enter the BIOS setup other than the usual DEL/F2. ASUS even provides a utility oddly "Fast Boot" (which I never enable) and a far more important button labeled Direct BIOS which, when run from Windows, forcibly enters the BIOS without the need to do anything else. When I run it, the system reboots, but I never see anything on the screen.

    I guessed maybe the BIOS settings had been corrupted, so I re-flashed it. Just another blank screen, and this returned the BIOS settings to their defaults, so from then on Windows would never boot, no longer how long I waited.

    Then I tried resetting the CMOS the patient way: I unplugged the machine for hours, removed the battery for quite some time, and moved the jumper to the Clear CMOS position, moved the jumper back, inserted a fresh battery, plugged the computer back in, and tried again. No change.

    Then I recalled that there's one other way to force your way into the BIOS setup that the manual never mentioned. I disconnected all mice and keyboards and rebooted, which causes the AMI BIOS to produce a distinctive beep complaining about the lack of a mouse & keyboard. After which, it sends you into the BIOS Setup.

    So, now I know with very high confidence that the machine IS entering the BIOS; it's just that I don't see a thing on either monitor connected to either graphics adapter.

    Does anyone know how I can solve this extremely difficult problem, please?

    Last edited: May 31, 2021

Share This Page