CPU goes to 100% when using internet, dl speed speed progressively declines

Discussion in 'Windows OS's' started by evilpedro, Mar 8, 2012.

  1. evilpedro

    evilpedro Geek Trainee

    Likes Received:
    Trophy Points:
    Hello, how we all doing?


    I however am not so good, someone told me that ones psychological well being is connected to the state of ones comp. Slow computer, a lot of irrtation. Obviously this is true.

    But I digress!

    Have an issue with high CPU that only occurs when internet/network card is involved. It happens both on cable/hardwire and wireless. This makes my whoel OS very laggy.

    According to asus liveupdate application I have the latest drivers for everything. I even updated my BIOS through it and it installed in windows, somehow. I went into BIOS to confirm it's the latest one, it is.

    I start OS, everything is fine.

    Fire up latest version of chrome, download anything (I think anything, at least from FTP) and CPU load increases as the download speed increases. It takes about 30-60 seconds for CPU to reach 100%, then the download speed decreases. If it gets up to 1/2/3 MB/s (megabyte) this happens. Close dl/finished/paused → CPU goes back down to normal levels of idling (which I suspect is unusually high in my case). Windows is not very snappy, but not all too laggy either. I get maxed out to 12MB/s with ubuntu ftp, CPU rises, dlspeed declines, just as described.

    If I close chrome then start again CPU spikes to 100% for half a second. Even just opening "my computer" causes this.

    This made me suspicious that it's simply my laptop that is weak, it can't handle high hd write without cpu going bonanas. However copying to HD from USBstick gets me a stable 22MB/s with CPU not noteworthy elevated.

    Problem persists with all programs under explorer.exe in processexplorer closed.

    Here's a screenshot I took a few minutes ago:

    processexplorer uses quite a bit, but if I close it and use windows task manager some other process will just replace it.

    Tested again with all eset smart security 5 modules disabled (the ones that can be disabled from right click of systray) - system idle even as much as 90% at one point.

    Just now I restarted without barely any services and applications: internet was not working. spike to 100% when opening my comp. Also restarted with my normal applications and services, cpu spikes to 100% from opening browser, and google docs.

    I tested without switch/router, that is only my comp connect straight to jacket in wall - problem remains. Also same problem occurs when I test my laptop on wireless on other networks.

    On fresh install of ubuntu 11.10 32 bit with a handful of software installed and no other modifications I get a stable cpu load of 85-90% with 8mb/s-10mb/s from ftp via browser. So no decline in dl/hd write speed in contrast to W7. No unnormal elevation of RAM, it rests at 1GB just as before dl started. Once dl finished cpu goes to 40% - 50%.

    If I recall correctly issue was there from the very beginning of purchase. Also problem persists after reinstalling windows 7 64bit ultimate and only installing a small number of software. Tried with installing all latest drivers too. In safe mode with networking enabled I still get 100% or nigh 100%, but dl does not go down, it remains stable at maxspeed.

    Also CPU goes down the moment I paus download instead of taking a while.

    Note that a couple of months ago the only way to make CPU come down from 100% was to reboot. Or manually disconnecting then reconnecting network cable. Or disable then enable network card (ethernet adapter) in device manager. Also this impacted OS much more than now, windows in general was very very laggy and opening webpages could take as long as 60 seconds or more.

    About two weeks ago I seemed to have found root cause. Disabled a software, problem went away. This could just have been a coincidence though, but I doubt that since before the only way to get rid of 100cpu consistently had been to reboot/disable network card. As soon as I closed the software cpu load was eased, all was well in the republic for some time.

    Then it reappared. I had installed a lot of applications, my memory is a little fuzzy and unfortunately I didn't take notes when it reappeared, but if I recall correctly it began when I installed another software to replace the previous uninstalled one. Uninstall of this new software did nothing..

    One guy from ASUS hotline said it's normal for this CPU to run high, but noone of they have said they have reports from other users of this high. The second time I called the other guy said this 100% problem is not normal. However other people on the internet says my problem is entirely normal performance from the hardware (http://answers.yahoo.com/question/index?qid=20120229152627AA0JJg9). What is your opinion?

    I also followed http://www.msfn.org/board/topic/140264-how-to-get-the-cause-of-high-cpu-usage-caused-by-apps - ntdll.dll seems to be the culprit causing chrome and antivirus make CPU run high. I have not idea what that is or what to do about it. The author of the thread told me what I already know, cpu is a bottleneck and that I should upgrade.

    Other actions tried:
    • ipconfig/dnsflush command in admin command prompt
    • Latest lan driver
    • CHKDSK
    • performed long test with drivefitness
    • looked for spyware/malware/virus. I don't have any.
    • wireless network card disabled
    • got info that windows throttling might cause this, went to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Multimedia\SystemProfile. But I had no multimedia key there, Maybe bc of enterprise.
    • I had manually entered DNS settings in network panel. Changed back to automatic.
    • disabled windows search indexing service + stopped it.
    • removed the ram stick that my retailer included as a bonus
    • no swapfile
    • disabeld high definition audio controller in device manager -> view by resource type
    • tried browsers tailored to take up only a small amount of resources
    • disabled all default (*) services from http://www.blackviper.com/2010/12/17/black-vipers-windows-7-service-pack-1-service-configurations/:
    • disabeld some other services
    On: Windows 7 Enterprise SP1 ver 6.1 build 7601 (not OEM) all current windows updates.

    Bios version 1.28.1119, manufacturer: american megatrends

    Link to my laptop ASUSTeK Computer Inc. - Notebooks- ASUS K52N

    Hardware specs

    Operating System
    MS Windows 7 Enterprise 64-bit SP1
    AMD V14052 °C
    Champlain 45nm Technology
    4,00 GB Dual-Channel DDR3 @ 533MHz (7-7-7-20)
    ASUSTeK Computer Inc. K52N (CPU 1)48 °C
    Generic PnP Monitor (1366x768@60Hz)
    ATI Mobility Radeon HD 4200 Series (ASUStek Computer Inc)
    Hard Drives
    313GB Western Digital WDC WD3200BEVT-80A0RT1 ATA Device (SATA)39 °C
    Optical Drives
    Realtek High Definition Audio
    Thanks in advance.

    PS: I first created a similar thread on anotfer forum, but they stopped replying I'm trying here again. Whether that was because they had no more good advice or if it simply got lost in the flood I don't know.
  2. Wildcard

    Wildcard Big Geek

    Likes Received:
    Trophy Points:

    So it seems to work fine with linux but not with windows? If you boot into safe mode with networking and test, does it still max out the processor? Is there an option in your BIOS for the laptop about using multiple cores? I know on some dell's there is an option that if it is not enabled, it only uses 2 out of 4 cores on the computer. Maybe some of the cores are not being used in your laptop? Also, try running sysinternals process explorer to see if it will give you any more information about what is happening as opposed to the windows process explorer. I believe it is free to download and gives more details about different processes.
  3. evilpedro

    evilpedro Geek Trainee

    Likes Received:
    Trophy Points:
    Hey wildcard, thank you for your time.

    No, same problem in ubuntu but it doesn't quite go to 100% and OS is not affected as much (and speed/hdwrite speed of download does not decrease. Sometimes it doesn't decrease in w7 either).

    As I said in the initial post yes safe mode with networking also max out processor (both clean install of w7 and my current setup).

    My BIOS is set to factory defaults and besides this CPU only has one core anyway. Process explorer is the one I've been using all the time, for example at the moment system idle process is taking 60%. This is with no active downloads whatsoever, the only traffic there is is the usual windows 7 one, which at the moment is 600 b/s download and 0.0 b/s upload. Just typing in openoffice makes cpu go to 100%, soffice.bin (openoffice) has at that time climbed to 70% cpu usage and system idle process dropped alot (albeit I'm being told idle process being at X % means the machine is NOT using that amount of %, which makes sense).

    This is even though I disabled and reenabled ethernet adapter in device manager.
  4. evilpedro

    evilpedro Geek Trainee

    Likes Received:
    Trophy Points:
    Now when using utorrent "Interrupts" took 50-60%. What is interrupts?
  5. RHochstenbach

    RHochstenbach Administrator

    Likes Received:
    Trophy Points:
    An interrupt is a signal from a device in your system that is asking the attention of your CPU. This could be an ethernet adapter, a sound card or a graphics card. In this case it simply means that your network adapter is transferring data.

Share This Page